[bug#63799,v2] gnu: Add ghc-xmobar
Commit Message
* gnu/packages/wm.scm (ghc-xmobar): New variable.
(xmobar)[inputs]: Remove everything except libxpm. Add ghc-xmobar.
[arguments]: Disable tests as they are run in ghc-xmobar. Configure only
the xmobar executable. Remove unnecessary phases.
[native-inputs]: Remove everything.
---
gnu/packages/wm.scm | 43 +++++++++++++++++++++++++++++++++++--------
1 file changed, 35 insertions(+), 8 deletions(-)
base-commit: 961ffca1c75141cbb351d143b22b673638e9659d
Comments
Hey,
> * gnu/packages/wm.scm (ghc-xmobar): New variable.
> (xmobar)[inputs]: Remove everything except libxpm. Add ghc-xmobar.
> [arguments]: Disable tests as they are run in ghc-xmobar. Configure only
> the xmobar executable. Remove unnecessary phases.
> [native-inputs]: Remove everything.
pushed as ba1fe203b293469e8db1a78e5090ecc711aaaba2 with minor modifications (added inherit from ghc-xmobar).
Cheers,
Lars
@@ -877,9 +877,9 @@ (define-public xmonad
tiled on several screens.")
(license license:bsd-3)))
-(define-public xmobar
+(define-public ghc-xmobar
(package
- (name "xmobar")
+ (name "ghc-xmobar")
(version "0.46")
(source (origin
(method url-fetch)
@@ -896,17 +896,18 @@ (define-public xmobar
ghc-alsa-mixer
ghc-dbus
ghc-hinotify
- ghc-http
+ ghc-http-client-tls
ghc-http-conduit
ghc-http-types
- ghc-iwlib
ghc-libmpd
ghc-netlink
+ ghc-cereal
ghc-old-locale
ghc-parsec-numbers
ghc-regex-compat
ghc-temporary
ghc-timezone-olson
+ ghc-timezone-series
ghc-x11
ghc-x11-xft
ghc-cairo
@@ -914,18 +915,44 @@ (define-public xmobar
libxpm))
(arguments
`(#:configure-flags (list "--flags=all_extensions")
- ;; Haddock documentation is for the library.
- #:haddock? #f
#:phases
(modify-phases %standard-phases
- (add-after 'register 'remove-libraries
+ (add-after 'install 'remove-binaries
(lambda* (#:key outputs #:allow-other-keys)
- (delete-file-recursively (string-append (assoc-ref outputs "out") "/lib"))))
+ (delete-file-recursively (string-append (assoc-ref outputs "out") "/bin"))))
(add-before 'build 'patch-test-shebang
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "test/Xmobar/Plugins/Monitors/AlsaSpec.hs"
(("/bin/bash") (which "bash"))))))))
(home-page "https://xmobar.org")
+ (synopsis "Haskell library for minimalistic text based status bars")
+ (description
+ "@code{ghc-xmobar} is the haskell library that @code{xmobar} is based on.
+It can be used to extend @code{xmobar} with other Haskell code.")
+ (license license:bsd-3)))
+
+(define-public xmobar
+ (package
+ (name "xmobar")
+ (version "0.46")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "xmobar" version))
+ (sha256
+ (base32
+ "0glpiq7c0qwfcxnc2flgzj7afm5m1a9ghzwwcq7f8q27m21kddrd"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "xmobar")))
+ (inputs
+ (list ghc-xmobar
+ libxpm))
+ (arguments
+ `(#:configure-flags (list "--flags=all_extensions" "exe:xmobar")
+ ;; Haddock documentation is for the library.
+ #:haddock? #f
+ ;; Tests are for the library.
+ #:tests? #f))
+ (home-page "https://xmobar.org")
(synopsis "Minimalistic text based status bar")
(description
"@code{xmobar} is a lightweight, text-based, status bar written in