diff mbox series

[bug#62903,1/8] gnu: sysbench: Build with mariadb.

Message ID ec0ad4741c2f9d91c0c65e7e4fd4d06aa4ea3bdf.1681738065.git.efraim@flashner.co.il
State New
Headers show
Series Remove mysql | expand

Commit Message

Efraim Flashner April 17, 2023, 1:32 p.m. UTC
* gnu/packages/benchmark.scm (sysbench)[arguments]: Remove mysql flag.
[inputs]: Remove mysql. Add mariadb:dev.
---
 gnu/packages/benchmark.scm | 9 +--------
 1 file changed, 1 insertion(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 0cc8def918..da2291194c 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -612,13 +612,6 @@  (define-public sysbench
     (arguments
      (list
       #:configure-flags #~(list "--with-pgsql"
-                                ;; Explicitly specify the library directory of
-                                ;; MySQL, otherwise `mysql_config` gets
-                                ;; consulted and adds unnecessary link
-                                ;; directives.
-                                (string-append "--with-mysql-libs="
-                                               #$(this-package-input "mysql")
-                                               "/lib")
                                 "--with-system-luajit"
                                 "--with-system-ck"
                                 ;; If we let the build tool select the most
@@ -679,7 +672,7 @@  (define-public sysbench
                          libxslt
                          docbook-xml
                          docbook-xsl))
-    (inputs (list ck libaio luajit mysql postgresql))
+    (inputs (list ck libaio luajit (list mariadb "dev") postgresql))
     (home-page "https://github.com/akopytov/sysbench/")
     (synopsis "Scriptable database and system performance benchmark")
     (description "@command{sysbench} is a scriptable multi-threaded benchmark