diff mbox series

[bug#70269] gnu: Add python-pybadges.

Message ID e5ffe23e93f708cb0c5a3f449b16ca36c5033550.1712527982.git.goodoldpaul@autistici.org
State New
Headers show
Series [bug#70269] gnu: Add python-pybadges. | expand

Commit Message

paul April 7, 2024, 10:13 p.m. UTC
* gnu/packages/python-web.scm (python-pybadges): New variable.

Change-Id: Idd53ddf94b24112015c0a0b82396cf366920417e
---
 gnu/packages/python-web.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: 69951a61a1d8f1f2135ea2dc836738be282b97bc

Comments

Nicolas Graves May 13, 2024, 5:40 a.m. UTC | #1
On 2024-04-08 00:13, Giacomo Leidi via Guix-patches via wrote:

> * gnu/packages/python-web.scm (python-pybadges): New variable.
>
> Change-Id: Idd53ddf94b24112015c0a0b82396cf366920417e
> ---
>  gnu/packages/python-web.scm | 34 ++++++++++++++++++++++++++++++++++
>  1 file changed, 34 insertions(+)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 9ad081beb1..da4f019476 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -9123,6 +9123,40 @@ (define-public python-whatthepatch
>       "This package provides a library to parse and apply patches.")
>      (license license:expat)))
>  
> +(define-public python-pybadges
> +  (package
> +    (name "python-pybadges")
> +    (version "3.0.1")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/google/pybadges")
> +                    (commit (string-append version))))

(string-append with a single string is a bit odd ;)

> +              (file-name (git-file-name name version))
> +              (sha256
> +               "1zgb9idz7m3mzf8wvik0gwmyrxp753axqjv2pab326cr5myj1s4b")))
> +    (build-system pyproject-build-system)
> +    (arguments
> +     (list
> +      #:test-flags
> +      #~'("-k"
> +          ;; Disable network dependent tests.
> +          "not test_changes and not test_not_image_url and not test_http_url")))
> +    (propagated-inputs (list python-jinja2 python-requests))
> +    (native-inputs (list python-flask
> +                         python-fonttools
> +                         python-nox
> +                         python-pillow
> +                         python-pytest
> +                         python-xmldiff))
> +    (home-page "https://github.com/google/pybadges")
> +    (synopsis
> +     "Libbrary and command-line tool for generating Github-style badges")
           ^ typo there
> +    (description
> +     "This package provides @code{python-pybadges}: a library and command-line
> +tool for generating Github-style badges.")

Maybe you can be a bit more descriptive: "as SVG images" in the Github
description is informative. I often also like (but I'm not sure it's a
norm) to write my synopsis as an action statement, such as "Generate
Github-style badges on the command-line".

> +    (license license:asl2.0)))

Otherwise LGTM.

> +
>  (define-public python-grid5000
>    (package
>      (name "python-grid5000")
>
> base-commit: 69951a61a1d8f1f2135ea2dc836738be282b97bc
paul May 13, 2024, 5:07 p.m. UTC | #2
Hi Nicolas,


Thank you for your review: I'm sending an updated patch.


giacomo
Nicolas Graves May 14, 2024, 8:10 p.m. UTC | #3
user guix
usertag 70269 + reviewed-looks-good
thanks

Guix QA review form submission:
LGTM

Items marked as checked: Lint warnings, Package builds, Commit messages, New package licenses, New package tests, New package synopsis and descriptions
Andreas Enge May 15, 2024, 1:58 p.m. UTC | #4
Hello,

the lonely "string-append" is still there, and the description a bit short.
I would not mind changing that myself, but since I am having trouble
downloading the patch anyway (clicking on "download raw message" in
issues.guix.gnu.org drops the attached commit), I will let you send in
a third version.

Thanks!

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9ad081beb1..da4f019476 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9123,6 +9123,40 @@  (define-public python-whatthepatch
      "This package provides a library to parse and apply patches.")
     (license license:expat)))
 
+(define-public python-pybadges
+  (package
+    (name "python-pybadges")
+    (version "3.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/google/pybadges")
+                    (commit (string-append version))))
+              (file-name (git-file-name name version))
+              (sha256
+               "1zgb9idz7m3mzf8wvik0gwmyrxp753axqjv2pab326cr5myj1s4b")))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      #~'("-k"
+          ;; Disable network dependent tests.
+          "not test_changes and not test_not_image_url and not test_http_url")))
+    (propagated-inputs (list python-jinja2 python-requests))
+    (native-inputs (list python-flask
+                         python-fonttools
+                         python-nox
+                         python-pillow
+                         python-pytest
+                         python-xmldiff))
+    (home-page "https://github.com/google/pybadges")
+    (synopsis
+     "Libbrary and command-line tool for generating Github-style badges")
+    (description
+     "This package provides @code{python-pybadges}: a library and command-line
+tool for generating Github-style badges.")
+    (license license:asl2.0)))
+
 (define-public python-grid5000
   (package
     (name "python-grid5000")