diff mbox series

[bug#60436] gnu: Add python-setuptools-lint.

Message ID d41be2518bb150cb647bbad8cdcd687df9619dce.1672436522.git.bjc@spork.org
State New
Headers show
Series [bug#60436] gnu: Add python-setuptools-lint. | expand

Commit Message

Brian Cully Dec. 30, 2022, 9:42 p.m. UTC
* gnu/packages/check.scm: (python-setuptools-lint) New variable.
---
 gnu/packages/check.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

宋文武 Feb. 6, 2023, 7:06 a.m. UTC | #1
Brian Cully <bjc@spork.org> writes:

> * gnu/packages/check.scm: (python-setuptools-lint) New variable.

Applied with adjusted synopsis and description:
--8<---------------cut here---------------start------------->8---
-    (synopsis "Setuptools command for pylint")
-    (description "Setuptools command for pylint")
+    (synopsis "Run pylint with @command{python setup.py lint}")
+    (description "This package expose pylint as a lint command into
+setup.py.")
--8<---------------cut here---------------end--------------->8---

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index aaa41777dc..7c351fb1ac 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2672,6 +2672,23 @@  (define-public python-pylint
 possible to write plugins to add your own checks.")
     (license license:gpl2+)))
 
+(define-public python-setuptools-lint
+  (package
+    (name "python-setuptools-lint")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "setuptools-lint" version))
+              (sha256
+               (base32
+                "16a1ac5n7k7sx15cnk03gw3fmslab3a7m74dc45rgpldgiff3577"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pylint))
+    (home-page "https://github.com/johnnoone/setuptools-pylint")
+    (synopsis "Setuptools command for pylint")
+    (description "Setuptools command for pylint")
+    (license license:bsd-3)))
+
 (define-public python-paramunittest
   (package
     (name "python-paramunittest")