From 438c2044f23e36fc1ddc07b388624194caebb077 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Wed, 26 Aug 2020 21:38:24 -0600
Subject: [PATCH 1/1] gnu: publicly define freedink-engine and freedink-data
* gnu/packages/games.scm: (freedink-engine): make public
(freedink-data): make public
---
gnu/packages/games.scm | 16 ++++++++++++----
1 file changed, 12 insertions(+), 4 deletions(-)
@@ -2861,7 +2861,7 @@ interface or via an external visual interface such as GNU XBoard.")
(ftp-directory . "/chess")))
(license license:gpl3+)))
-(define freedink-engine
+(define-public freedink-engine
(package
(name "freedink-engine")
(version "109.6")
@@ -2891,7 +2891,16 @@ interface or via an external visual interface such as GNU XBoard.")
(invoke "autoreconf")
;; Build fails when autom4te.cache exists.
(delete-file-recursively "autom4te.cache")
- #t)))))
+ #t))
+ (add-after 'install 'delete-freedinkedit-desktop
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; freedinkedit does not know where to find freedink data
+ ;; freedink data is read-only, so it cannot be edited anyway.
+ ;; TODO: fix freedink.desktop
+ (delete-file-recursively (string-append
+ out "/share/applications"))
+ #t))))))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)
("cxxtest" ,cxxtest)
@@ -2913,7 +2922,7 @@ game data files but it also supports user-produced game mods or \"D-Mods\".
To that extent, it also includes a front-end for managing all of your D-Mods.")
(license license:gpl3+)))
-(define freedink-data
+(define-public freedink-data
(package
(name "freedink-data")
(version "1.08.20190120")
@@ -2971,7 +2980,6 @@ and its numerous D-Mods.")
(arguments
'(#:builder (begin
(use-modules (guix build utils))
-
(let* ((output (assoc-ref %outputs "out"))
(bin (string-append output "/bin"))
(executable (string-append bin "/freedink")))
--
2.28.0