From 812077cee02fc4e0f50b69810209b1b40e60dfc0 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Mon, 9 Dec 2019 18:31:12 -0700
Subject: [PATCH 2/5] gnu: Add python-funcparserlib
* gnu/packages/python-xyz.scm (python-funcparserlib): New variable.
---
gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
@@ -16798,3 +16798,30 @@ converters and more, those based on the library itself.")
"Makes entry_points specified in setup.py load more quickly")
(license license:bsd-3)))
+(define-public python-funcparserlib
+ (package
+ (name "python-funcparserlib")
+ (version "0.3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "funcparserlib" version))
+ (sha256
+ (base32
+ "07f9cgjr3h4j2m67fhwapn8fja87vazl58zsj4yppf9y3an2x6dp"))))
+ (native-inputs
+ `(("python-tox" ,python-tox)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "tox"))))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/vlasovskikh/funcparserlib")
+ (synopsis
+ "Recursive descent parsing library based on functional combinators")
+ (description
+ "Recursive descent parsing library based on functional combinators")
+ (license license:expat)))
--
2.24.0