diff mbox series

[bug#64222,3/4] gnu: Add go-github-com-delthas-go-localeinfo

Message ID c616164119d09428df20cbf6ad5cc421a3e3fc8d.1687431267.git.mcsinyx@disroot.org
State New
Headers show
Series Add senpai IRC client | expand

Commit Message

ashish.is--- via Guix-patches" via June 22, 2023, 10:54 a.m. UTC
gnu/packages/golang.scm (go-github-com-delthas-go-localeinfo): New variable.

Signed-off-by: Nguyễn Gia Phong <mcsinyx@disroot.org>
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9ffe8b3e7cbf..d2d7f855871d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9953,6 +9953,28 @@  (define-public go-github-com-delthas-go-libnp
       (description "@code{go-libnp} is a tiny cross-platform library for extracting information about the music/image/video that is Now Playing on the system.")
       (license license:expat))))
 
+(define-public go-github-com-delthas-go-localeinfo
+  (let ((commit "686a1e18511819b2f1625f00437f6e1246c04a5d"))
+    (package
+      (name "go-github-com-delthas-go-localeinfo")
+      (version (git-version "0.0.0" "0" commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/delthas/go-localeinfo")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                  (base32
+                    "0r0v42ggvyss8327nggwinxl42pj4l0dwz96g9wk1w8h8vmfrh0z"))))
+      (build-system go-build-system)
+      (arguments `(#:tests? #f ; FIXME: tests assume certain locale
+                   #:import-path "github.com/delthas/go-localeinfo"))
+      (home-page "https://github.com/delthas/go-localeinfo")
+      (synopsis "Library for extracting locale information")
+      (description "@code{go-localeinfo} extracts monetary/numeric/time formatting information, rather than the current locale name.")
+      (license license:expat))))
+
 (define-public go-github-com-prometheus-common
   (package
     (name "go-github-com-prometheus-common")