diff mbox series

[bug#63610,1/3] gnu: graphviz: Add "minimal" variant.

Message ID aafb612cadecd2f960dac66fd776108eca892bb3.1684598152.git.ludo@gnu.org
State New
Headers show
Series Add 'graphviz-minimal' and have Guix depend on it | expand

Commit Message

Ludovic Courtès May 20, 2023, 4:11 p.m. UTC
* gnu/packages/graphviz.scm (graphviz-minimal): New variable.
---
 gnu/packages/graphviz.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 26ee96afd4..30dd6d3405 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -1,5 +1,5 @@ 
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2015, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
 ;;; Copyright © 2017, 2018, 2019, 2022 Ricardo Wurmus <rekado@elephly.net>
@@ -124,6 +124,13 @@  (define-public graphviz
      '((release-monitoring-url . "https://graphviz.org/download/source/")))
     (license license:epl1.0)))
 
+(define-public graphviz-minimal
+  (package/inherit graphviz
+    (name "graphviz-minimal")
+    (inputs (modify-inputs (package-inputs graphviz)
+              (delete "libxrender" "libx11" "pango" "libxaw")))
+    (synopsis "Graph visualization software (without X11 support)")))
+
 (define-public python-graphviz
   (package
     (name "python-graphviz")