diff mbox series

[bug#42460,2/2] gnu: vlc: Add support for gme.

Message ID aa0baa7d-2503-f10f-0477-c8c66726f8cc@gmail.com
State New
Headers show
Series gnu: vlc: add support for MIDI and chiptunes | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jesse Gibbons July 21, 2020, 6:29 a.m. UTC
* gnu/packages/video.scm: vlc (inputs): Add libgme.
---
gnu/packages/video.scm | 4 ++++
1 file changed, 4 insertions(+)

("libmad" ,libmad)
@@ -1321,6 +1324,7 @@ videoformats depend on the configuration flags of 
ffmpeg.")
`(#:configure-flags
`("BUILDCC=gcc"
"--enable-fluidsynth"
+ "--enable-gme"
,(string-append "LDFLAGS=-Wl,-rpath -Wl,"
(assoc-ref %build-inputs "ffmpeg")
"/lib")) ;needed for the tests
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a4e097e9a2..6b57d384e1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -44,6 +44,7 @@ 
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -131,6 +132,7 @@ 
#:use-module (gnu packages markup)
#:use-module (gnu packages maths)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages music)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
#:use-module (gnu packages ocr)
@@ -1268,6 +1270,7 @@  videoformats depend on the configuration flags of 
ffmpeg.")
("libdvdread" ,libdvdread)
("libebml" ,libebml)
("libgcrypt" ,libgcrypt)
+ ("libgme" ,libgme)
("libidn" ,libidn)
("libkate" ,libkate)