diff mbox series

[bug#62085] gnu: Add python-mohawk.

Message ID a014b73f-409f-ea44-b5e0-244c12a2727e@disroot.org
State New
Headers show
Series [bug#62085] gnu: Add python-mohawk. | expand

Commit Message

Adam Faiz March 9, 2023, 5:27 p.m. UTC
From 705c878397db8683c40ba8b9f37be525e8208d88 Mon Sep 17 00:00:00 2001
Message-Id: <705c878397db8683c40ba8b9f37be525e8208d88.1678382603.git.adam.faiz@disroot.org>
In-Reply-To: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678382602.git.adam.faiz@disroot.org>
References: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678382602.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 10 Mar 2023 00:35:43 +0800
Subject: [PATCH] gnu: Add python-mohawk.

* gnu/packages/python-web.scm (python-mohawk): New variable.
---
  gnu/packages/python-web.scm | 22 ++++++++++++++++++++++
  1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8a73c929a1..b8354f9799 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1588,6 +1588,28 @@  (define-public python-minio
  Amazon S3 compatible object storage server.")
      (license license:asl2.0)))
  
+(define-public python-mohawk
+  (package
+    (name "python-mohawk")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "mohawk" version))
+              (sha256
+               (base32
+                "08wppsv65yd0gdxy5zwq37yp6jmxakfz4a2yx5wwq2d222my786j"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-mock
+           python-nose))
+    (propagated-inputs
+     (list python-six))
+    (home-page "https://github.com/kumar303/mohawk")
+    (synopsis "Library for Hawk HTTP authorization")
+    (description "Mohawk is an alternate Python implementation
+of the Hawk HTTP authorization scheme.")
+    (license license:bsd-3)))
+
  (define-public python-pycurl
    (package
      (name "python-pycurl")