@@ -118,10 +118,10 @@ (define-module (gnu packages finance)
#:use-module (gnu packages xml)
#:use-module (gnu packages gnuzilla))
-(define-public bitcoin-core-0.21
+(define-public bitcoin-core-22.0
(package
(name "bitcoin-core")
- (version "0.21.2")
+ (version "22.0")
(source (origin
(method url-fetch)
(uri
@@ -129,7 +129,7 @@ (define-public bitcoin-core-0.21
version "/bitcoin-" version ".tar.gz"))
(sha256
(base32
- "17nvir1yc6mf4wr1fn4xsabw49cd5p9vig8wj77vv4anzi8zfij1"))))
+ "0fv1z5dl5pxi08sg7xj541445l3y7akdaz7sbrav2j3hnn4x1sfh"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
@@ -196,10 +196,10 @@ (define-public bitcoin-core-0.21
line client and a client based on Qt.")
(license license:expat)))
-(define-public bitcoin-core-0.20
+(define-public bitcoin-core-0.21
(package
- (inherit bitcoin-core-0.21)
- (version "0.20.2")
+ (inherit bitcoin-core-22.0)
+ (version "0.21.2")
(source (origin
(method url-fetch)
(uri
@@ -207,7 +207,7 @@ (define-public bitcoin-core-0.20
version "/bitcoin-" version ".tar.gz"))
(sha256
(base32
- "14smp5vmh7baabl856wlg7w7y5910jhx6c02mlkm4hkywf3yylky"))))))
+ "17nvir1yc6mf4wr1fn4xsabw49cd5p9vig8wj77vv4anzi8zfij1"))))))
;; The support lifetimes for bitcoin-core versions can be found in
;; <https://bitcoincore.org/en/lifecycle/#schedule>.
From e1fc0bf0ffccaf9e728fbc03419eddfde4fb8b4d Mon Sep 17 00:00:00 2001 From: ZmnSCPxj <ZmnSCPxj@protonmail.com> Date: Wed, 9 Feb 2022 07:03:26 +0000 Subject: [PATCH] gnu: Update bitcoin-core to 22.0, remove 0.20 due to end-of-life. * gnu/packages/finance.scm (bitcoin-core-22.0): New variable. (bitcoin-core-0.21): Changed to inherit from bitcoin-core-22.0. (bitcoin-core-0.20): Remove due to end-of-life. --- gnu/packages/finance.scm | 14 +++++++------- 1 file changed, 7 insertions(+), 7 deletions(-) base-commit: f7afefba00b65e94d073af3af2278a076c89dbc1 -- 2.34.0