diff mbox series

[bug#70780,v2,2/2] gnu: Add libscfg.

Message ID 9889610f1c2bc612ef933164f3bf57ad4202aac3.1715343899.git.w@wmeyer.eu
State New
Headers show
Series [bug#70780,v2,1/2] gnu: kanshi: Update to 1.6.0. | expand

Commit Message

Wilko Meyer May 10, 2024, 12:25 p.m. UTC
* gnu/packages/serialization.scm (libscfg): New variable.
* gnu/packages/serialization.scm: Add copyright.

Change-Id: I0096745f2971799bd0c9955cddeed24f0846f075
---
 gnu/packages/serialization.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Ludovic Courtès May 31, 2024, 11:47 a.m. UTC | #1
Hi,

Wilko Meyer <w@wmeyer.eu> skribis:

> * gnu/packages/serialization.scm (libscfg): New variable.
> * gnu/packages/serialization.scm: Add copyright.

The second line is unnecessary.

> +    (synopsis "A C library for scfg")
> +    (description "This package provides a C library for scfg.")

Please run ‘guix lint’ (it’ll complain about the synopsis) and check out
<https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html>.
:-)

Could yoiu send updated patches addressing this?  Also, please make sure
the libscfg patch comes first in the series.

Thanks in advance!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 331fae80cf..be1410255a 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2024 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2024 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -420,6 +421,25 @@  (define-public lua5.2-libmpack
     (inputs
      `(("lua" ,lua-5.2)))))
 
+(define-public libscfg
+  (package
+    (name "libscfg")
+    (version "0.1.1")
+    (home-page "https://git.sr.ht/~emersion/libscfg")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~emersion/libscfg")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1b1ps7wba4anm3x1yndnd730dwl6rdz3zwjgxmsyq31fnjrjydv9"))))
+    (build-system meson-build-system)
+    (synopsis "A C library for scfg")
+    (description "This package provides a C library for scfg.")
+    (license license:expat)))
+
 (define-public libyaml
   (package
     (name "libyaml")