@@ -9524,20 +9524,20 @@ (define-public modprobed-db
(string-append
(search-input-file inputs "/bin/modprobe") " "))))))))
(inputs (list coreutils kmod gawk glibc grep sed))
- (home-page "https://wiki.archlinux.org/index.php/Modprobed-db")
- (synopsis "Keep track of EVERY kernel module that has ever been probed")
+ (home-page "https://wiki.archlinux.org/title/Modprobed-db")
+ (synopsis "Keep track of Linux modules that have been probed")
(description
- "@code{Modprobed-db} is a useful utility for users wishing to build a
-minimal kernel via a @code{make localmodconfig}. In a nutshell, this make
+ "Modprobed-db is a useful utility for users wishing to build a minimal
+kernel via a @code{make localmodconfig}. In a nutshell, this @command{make}
target creates a config based on the current config and a list of modules you
-define (@code{modprobed-db} keeps for you). It then disables any module
-option that is not needed thus not building hundreds/potentially thousands of
-extraneous modules. This results in a system-specific, streamlined kernel
-package and footprint as well as reduced compilation times.
+define (that @command{modprobed-db} keeps for you). It then disables any
+module option that is not needed thus not building extraneous modules. This
+results in a system-specific, streamlined kernel package and footprint as well
+as reduced compilation times.
-@code{Modprobed-db} simply logs every module ever probed on the target system
-to a text-based database (@code{$XDG_CONFIG_HOME/modprobed-db}) which can be
-read directly by @code{make localmodconfig} as described above.")
+Modprobed-db simply logs every module ever probed on the target system to a
+text-based database (@file{$XDG_CONFIG_HOME/modprobed-db}), which can be read
+directly by @code{make localmodconfig} as described above.")
(license license:expat)))
(define-public kconfig-hardened-check
Hilton Chain <hako@ultrarare.space> skribis: > * gnu/packages/linux.scm (modprobed-db): New variable. Applied with the cosmetic changes below, thanks! Ludo’.