@@ -593,6 +593,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/suckless.scm \
%D%/packages/sugar.scm \
%D%/packages/swig.scm \
+ %D%/packages/sycl.scm \
%D%/packages/sync.scm \
%D%/packages/syncthing.scm \
%D%/packages/synergy.scm \
@@ -17,11 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages sycl)
- #:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
- #:use-module (guix build-system python)
- #:use-module (guix download)
- #:use-module (guix utils)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -43,18 +39,20 @@ (define-public opensycl
(name "opensycl")
(version "0.9.4")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/OpenSYCL/OpenSYCL/"
- "archive/refs/tags/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenSYCL/OpenSYCL/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1i2i7r16k2kyjp4yrjp0ywnavr8aa6pfcrwb5xp9c4n8j4qm6qk2"))))
+ "0nynb93b68ghn1i1bsjvbbxpnh5b1yiw9jhhww1q1gi7w182x2g5"))))
(build-system cmake-build-system)
(native-inputs (list clang-15 llvm-15 python spirv-tools))
(inputs (list boost rocm-opencl-runtime spirv-headers))
(arguments `(#:tests? #f)) ; no tests
(home-page "https://github.com/OpenSYCL/OpenSYCL")
- (synopsis "Modern SYCL implementation")
+ (synopsis "Implementation of the SYCL programming language for accelerators")
(description
"Open SYCL is a modern SYCL implementation targeting CPUs and GPUs from all
major vendors that supports many use cases and approaches for implementing SYCL")
Hi, Andy Tai <atai@atai.org> skribis: > * gnu/packages/sycl.scm (opensycl): New variable Applied with the changes below, some suggested by ‘guix lint’. Thanks! Ludo’.