@@ -168,35 +168,30 @@ (define-public a4pdf
(license license:asl2.0)))
(define-public diffpdf
- (let ((commit "ba68231d3d05e0cb3a2d4a4fca8b70d4044f4303"))
+ (let ((commit "ba68231d3d05e0cb3a2d4a4fca8b70d4044f4303")
+ (revision "1"))
(package
(name "diffpdf")
- (version "2.1.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/eang/diffpdf")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1vwgv28b291lrcs9fljnlbnicv16lwj4vvl4bz6w3ldp9n5isjmf"))))
+ (version (git-version "2.1.3.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/eang/diffpdf")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vwgv28b291lrcs9fljnlbnicv16lwj4vvl4bz6w3ldp9n5isjmf"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f))
- (inputs
- (list
- extra-cmake-modules
- qtbase-5
- qttools-5
- poppler-qt5))
- (native-inputs
- (list pkg-config))
+ (inputs (list qtbase-5 qttools-5 poppler-qt5))
+ (native-inputs (list pkg-config extra-cmake-modules))
(home-page "http://www.qtrac.eu/diffpdf-foss.html")
(synopsis "Compare two PDF files")
(description
- "@command{diffpdf} offers three comparison modes: Words, Characters,
-and Appearance.")
+ "@command{diffpdf} lets you compare PDF files, offering three
+comparison modes: words, characters, and appearance.")
(license license:gpl2))))
(define-public extractpdfmark
Hi, Olivier Dion <olivier.dion@polymtl.ca> skribis: > * gnu/packages/pdf.scm (diffpdf): New variable. Applied with the changes below: addressing ‘guix lint’ warnings, using a version string that matches the latest tag, and passing it through ‘guix style’. Ludo’.