diff mbox series

[bug#46210] Add drumgizmo

Message ID 877dntfdsk.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State New
Headers show
Series [bug#46210] Add drumgizmo | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Nicolò Balzarotti Jan. 31, 2021, 1:15 p.m. UTC
Hi guix!

For folks into music production, this patch set adds drumgizmo, an high
quality MIDI drum.  It comes with a standalone application and an LV2
plugin (VST should also be there, but I could not build it).  I tested
both the cli and the lv2 plugin (inside carla) and they work fine.

Along with it, I added dgedit, a drumkit kit editor.

I also added three drumkits.  Those are big (2 to 5Gb), and the build is
just extract+copy, so I don't know if I should add #:substitutable? #f.
There's no standard path for those, so I'm placing them under
share/drumkits/DRUMKIT_NAME.

guix lint does not complain and they all build fine

Thanks!
diff mbox series

Patch

From 9a607ff9694987aef1bd48cd4aa90631aca736e0 Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Sun, 31 Jan 2021 11:39:41 +0100
Subject: [PATCH 6/6] gnu: Add drumgizmo-aasimonster.

* gnu/packages/audio.scm (drumgizmo-aasimonster): New variable.
---
 gnu/packages/audio.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 95fa59ae29..c2d7572883 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4962,6 +4962,44 @@  and mix them with a multichannel approach.  It is comparable to that of mixing
 a real drumkit that has been recorded with a multimic setup.")
     (license license:lgpl3+)))
 
+(define-public drumgizmo-aasimonster
+  (package
+    (name "drumgizmo-aasimonster")
+    (version "2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append
+         "https://drumgizmo.org/kits/Aasimonster/aasimonster"
+         (string-replace-substring version "." "_") ".zip"))
+       (sha256
+        (base32 "1pq7a9r2vsqpanpwyhljj3jf2dfg8m96npkk9y52qq73v8vn7sz0"))))
+    (build-system copy-build-system)
+    (arguments
+     `(#:install-plan
+       '(("." "share/drumkits/Aasimonster/"))))
+    (native-inputs
+     `(("unzip" ,unzip)))
+    (home-page "https://drumgizmo.org/wiki/doku.php?id=kits:the_aasimonster")
+    (synopsis "Large Deathmetal drumkit for drumgizmo")
+    (description "The Aasimonster is a large deathmetal drumkit used to track
+the “Rise of the Rotten” record by the Danish deathmetal band DIE.
+
+It contains the following components:
+
+@enumerate
+@item 2 kickdrums
+@item 3 hanging toms
+@item 1 floor tom
+@item 2 16“ crash cymbals
+@item 1 18” china cymbal
+@item 2 small china cymbals (Stagg 8“ and 10”)
+@item 1 Zilbel
+@item 1 Ride cymbal
+@end enumerate")
+    (license license:cc-by4.0)))
+
 (define-public drumgizmo-crocellkit
   (package
     (name "drumgizmo-crocellkit")
-- 
2.30.0