diff mbox series

bug#59739: [PATCH] tests: Add gdm test.

Message ID 874jualt53.fsf@gnu.org
State New
Headers show
Series bug#59739: [PATCH] tests: Add gdm test. | expand

Commit Message

Ludovic Courtès Dec. 4, 2022, 10:07 p.m. UTC
Hello,

mirai@makinata.eu skribis:

> From: Bruno Victal <mirai@makinata.eu>
>
> * gnu/tests/gdm.scm: New file.
> * gnu/local.mk: Register it.
> ---
>
> Small test suite for investigating the issue 57589 (https://issues.guix.gnu.org/57589)
> basing on the hint at reply #6.

Excellent!  The tests all had the same name; I fixed that so I could
actually run them all (see below).

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/tests/gdm.scm b/gnu/tests/gdm.scm
index 137e70544e..4f67551e63 100644
--- a/gnu/tests/gdm.scm
+++ b/gnu/tests/gdm.scm
@@ -109,18 +109,18 @@  (define test
 
 (define %test-gdm-x11
   (system-test
-   (name "gdm")
+   (name "gdm-x11")
    (description "Basic tests for the GDM service. (X11)")
    (value (run-gdm-test))))
 
 (define %test-gdm-wayland
   (system-test
-   (name "gdm")
+   (name "gdm-wayland")
    (description "Basic tests for the GDM service. (Wayland)")
    (value (run-gdm-test #:wayland? #t))))
 
 (define %test-gdm-wayland-tmpfs
   (system-test
-   (name "gdm")
+   (name "gdm-wayland-tmpfs")
    (description "Basic tests for the GDM service. (Wayland, /tmp as tmpfs)")
    (value (run-gdm-test #:wayland? #t #:tmp-tmpfs? #t))))