diff mbox series

[bug#67131,v2,4/7] gnu: Add python-pygame-menu.

Message ID 86d8da19-823f-79d0-b760-ba8706958835@disroot.org
State New
Headers show
Series [bug#67131,v2,1/7] gnu: Add python-neteria. | expand

Commit Message

Adam Faiz Nov. 13, 2023, 4:11 a.m. UTC
From 5550355f5dbed58b3e7a188d2c1c8f1aeb646c40 Mon Sep 17 00:00:00 2001
Message-ID: <5550355f5dbed58b3e7a188d2c1c8f1aeb646c40.1699848337.git.adam.faiz@disroot.org>
In-Reply-To: <c3534b088236ae688d64aa91046c24774ac259a6.1699848337.git.adam.faiz@disroot.org>
References: <c3534b088236ae688d64aa91046c24774ac259a6.1699848337.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 13 Nov 2023 11:41:54 +0800
Subject: [PATCH v2 4/7] gnu: Add python-pygame-menu.

* gnu/packages/game-development.scm (python-pygame-menu): New variable.
---
 gnu/packages/game-development.scm | 32 +++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index ed9e8cb826..2222183970 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1399,6 +1399,38 @@  (define-public python-pygame
                    license:public-domain
                    license:lgpl2.1+))))
 
+(define-public python-pygame-menu
+  (package
+    (name "python-pygame-menu")
+    (version "4.4.3")
+    (source
+     ;; Tests not included in release.
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/ppizarror/pygame-menu")
+           (commit version)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0s7w8z931iw9rzsaq9810lbrgba9i2qhkryf0y011njc6bxhf6w4"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Some tests depend on having a mixer, and a few assertions fail
+     (list #:tests? #f))
+    (propagated-inputs (list python-pygame python-pyperclip
+                             python-typing-extensions))
+    (native-inputs (list python-nose2))
+    (home-page "https://pygame-menu.readthedocs.io")
+    (synopsis "Menu for pygame")
+    (description
+     "Pygame-menu is a python-pygame library for creating menus and GUIs.
+It supports several widgets, such as buttons, color inputs, clock objects,
+drop selectors, frames, images, labels, selectors, tables, text inputs,
+color switches, and many more, with multiple options to customize.")
+    (license license:expat)))
+
 (define-public python-pyglet
   (package
     (name "python-pyglet")