From a2ed7bff6ff65518910edac44f7e498418042bfb Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Fri, 3 Jul 2020 18:35:57 -0600
Subject: [PATCH v2 1/1] gnu: enigma: Fix enigma.
* gnu/packages/games.scm: enigma(phases): Add 'fix-proxy.
---
gnu/packages/games.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
@@ -5872,7 +5872,16 @@ The Flag. You can even design your own maps!")
(substitute* "src/main.cc"
(("#include <SDL_(image|ttf|mixer).h>" line header)
(string-append "#include \"SDL/SDL_" header ".h\"")))
- #t)))))
+ #t))
+ (add-after 'find-sdl 'fix-proxy
+ (lambda _
+ ;; Build fails when making src/lev/Proxy.cc because
+ ;; the wrong operator overload is used.
+ (substitute* "src/lev/Proxy.cc"
+ (("ifs != NULL")
+ "!ifs"))
+ #t))
+ )))
(inputs
`(("xerces-c" ,xerces-c)
("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
--
2.27.0