diff mbox series

[bug#37725] gnu: lxqt-config: Add libkscreen as propagated-inputs.

Message ID 7f6cec63aa60.1c74a5ea44b25a07@guile.gnu.org
State New
Headers show
Series [bug#37725] gnu: lxqt-config: Add libkscreen as propagated-inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Gerd Heber via web Sept. 16, 2020, 8:40 a.m. UTC
Hi,

Finally we can fix this issue with wrapping the `lxqt-config` and `lxqt-config-monitor` and add the `libkscreen` path to `PATH` environment path. I updated based on this patch and it fixed.
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index af452a9903..0ba1a0c7b3 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -418,7 +418,16 @@  the operating system LXQt is running on.")
                (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
                 (string-append (assoc-ref outputs "out")
                                "/share/lxqt/translations")))
-             #t)))))
+             #t))
+         (add-after 'install 'wrap-for-libkscreen
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out              (assoc-ref outputs "out"))
+                   (libkscreen       (assoc-ref %build-inputs "libkscreen")))
+                     (wrap-program (string-append out "/bin/lxqt-config")
+                         `("PATH" ":" prefix (,(string-append libkscreen "/bin/"))))
+                     (wrap-program (string-append out "/bin/lxqt-config-input")
+                         `("PATH" ":" prefix (,(string-append libkscreen "/bin/"))))
+             #t))))))
     (home-page "https://lxqt.github.io")
     (synopsis "Tools to configure LXQt and the underlying operating system")
     (description "lxqt-config is providing several tools involved in the