diff mbox series

[bug#68014] gnu: admin: Add zzz.

Message ID 76c32f8ea952a9f9f6904d9a69a7bcb1@disroot.org
State New
Headers show
Series [bug#68014] gnu: admin: Add zzz. | expand

Commit Message

ashish.is--- via Guix-patches" via Dec. 24, 2023, 7:06 p.m. UTC
This patch adds zzz, a simple script to suspend or hibernate your 
computer.
diff mbox series

Patch

From 7931f22535d3322e83f89383e572cb6ff845dfc3 Mon Sep 17 00:00:00 2001
From: Luis Guilherme Coelho <lgcoelho@disroot.org>
Date: Sun, 24 Dec 2023 16:04:16 -0300
Subject: [PATCH] gnu: admin: Add zzz.

---
 gnu/packages/admin.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5442714665..b168936586 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -62,6 +62,7 @@ 
 ;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;; Copyright © 2023 Tobias Kortkamp <tobias.kortkamp@gmail.com>
 ;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
+;;; Copyright © 2023 Luis Guilherme Coelho <lgcoelho@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -79,6 +80,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages admin)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system cargo)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system emacs)
@@ -6038,3 +6040,28 @@  (define-public bfs
 versions of @command{find}, including POSIX, GNU, and *BSD find.")
     (home-page "https://tavianator.com/projects/bfs.html")
     (license license:bsd-0)))
+
+(define-public zzz
+  (let ((commit "329b891426efc093ad8c65e96364427c2fb25b54")
+        (revision "0"))
+    (package
+      (name "zzz")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/void-linux/void-runit")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1lgf3maqw2j9hjzq0bkrvbl7vbh4zpppm9cdl9hvf54kbxcn2v9i"))))
+      (build-system copy-build-system)
+      (arguments
+       (list #:install-plan #~'(("zzz" "bin/")
+                                ("zzz.8" "share/man/man8/"))))
+      (home-page "https://github.com/void-linux/void-runit")
+      (synopsis "Simple script to suspend or hibernate your computer.")
+      (description "Simple script to suspend or hibernate your computer.  It
+suports hooks before and after suspending.")
+      (license license:cc0))))
-- 
2.41.0