diff mbox series

[bug#42453] gnu: chroma: Fix build.

Message ID 6827eede-64e7-52e0-529a-08b79b1598db@gmail.com
State Accepted
Headers show
Series [bug#42453] gnu: chroma: Fix build. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jesse Gibbons July 21, 2020, 6:05 a.m. UTC
* gnu/packages/games.scm: chroma:

[configure-flags]: Add "CFLAGS=-fgnu89-inline"
---
gnu/packages/games.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès July 21, 2020, 4:30 p.m. UTC | #1
Hi,

Jesse Gibbons <jgibbons2357@gmail.com> skribis:

> * gnu/packages/games.scm: chroma:
>
> [configure-flags]: Add "CFLAGS=-fgnu89-inline"
> ---
> gnu/packages/games.scm | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index f4d75eedd4..cff1c0af99 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -40,7 +40,7 @@
> ;;; Copyright © 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
> ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
> ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
> -;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
> +;;; Copyright © 2019, 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
> ;;; Copyright © 2019 Dan Frumin <dfrumin@cs.ru.nl>
> ;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
> ;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
> @@ -5895,7 +5895,8 @@ with the mouse isn’t always trivial.")
> "047sf00x71xbmi8bqrhfbmr9bk89l2gbykkqsfpw4wz6yfjscs6y"))))
> (build-system gnu-build-system)
> (arguments
> - `(#:tests? #f)) ; no tests included
> + `(#:tests? #f ; no tests included
> + #:configure-flags '("CFLAGS=-fgnu89-inline"))) ; fix inlines

Looks like your email client mangled the patch, probably due to
“format=flowed”.

Could you try sending it with ‘git send-email’ or as an attachment, to
42453@debbugs.gnu.org?

TIA!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f4d75eedd4..cff1c0af99 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -40,7 +40,7 @@ 
;;; Copyright © 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;; Copyright © 2019, 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
;;; Copyright © 2019 Dan Frumin <dfrumin@cs.ru.nl>
;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
@@ -5895,7 +5895,8 @@  with the mouse isn’t always trivial.")
"047sf00x71xbmi8bqrhfbmr9bk89l2gbykkqsfpw4wz6yfjscs6y"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f)) ; no tests included
+ `(#:tests? #f ; no tests included
+ #:configure-flags '("CFLAGS=-fgnu89-inline"))) ; fix inlines
(inputs
`(("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
("freetype" ,freetype)