diff mbox series

[bug#50091,12/21] gnu: openblas: Fix building on riscv64-linux.

Message ID 3c3666cb80fc774655f8fb7146df0a20e82481a2.1629193993.git.efraim@flashner.co.il
State New
Headers show
Series Add riscv64 support | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Aug. 17, 2021, 10:19 a.m. UTC
* gnu/packages/maths.scm (openblas)[arguments]: Adjust make-flags on
riscv64-linux to target the correct architecture when building for
riscv64-linux.
---
 gnu/packages/maths.scm | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a7931e6eeb..7eac94f2a1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4075,6 +4075,8 @@  parts of it.")
                   ;; Failed to detect CPU.
                   ((string-prefix? "armhf" system)
                    '("TARGET=ARMV7"))
+                  ((string-prefix? "riscv64" system)
+                   '("TARGET=RISCV64_GENERIC"))
                   (else '()))))
        ;; no configure script
        #:phases