diff mbox series

[bug#63576,v1,3/4] gnu: Add aarch64-none-elf-newlib.

Message ID 20230518182814.15881-3-GNUtoo@cyberdimension.org
State New
Headers show
Series Add aarch64-none-elf-gcc-toolchain. | expand

Commit Message

Denis 'GNUtoo' Carikli May 18, 2023, 6:28 p.m. UTC
* gnu/packages/aarch64-none-elf-toolchain.scm (aarch64-none-elf-newlib): New
  variable.
---
 gnu/packages/aarch64-none-elf-toolchain.scm | 49 ++++++++++++++++++++-
 1 file changed, 48 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/aarch64-none-elf-toolchain.scm b/gnu/packages/aarch64-none-elf-toolchain.scm
index 88a2abb1f9..9863e65dad 100644
--- a/gnu/packages/aarch64-none-elf-toolchain.scm
+++ b/gnu/packages/aarch64-none-elf-toolchain.scm
@@ -17,11 +17,15 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages aarch64-none-elf-toolchain)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix gexp)
   #:use-module (guix utils)
+  #:use-module (guix download)
   #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
   #:use-module (gnu packages cross-base)
-  #:use-module (gnu packages gcc))
+  #:use-module (gnu packages gcc)
+  #:use-module (gnu packages texinfo))
 
 (define-public aarch64-none-elf-binutils
   (package
@@ -81,3 +85,46 @@  (define aarch64-none-elf-gcc
       (native-inputs
        `(("gcc" ,gcc)
          ,@(package-native-inputs xgcc))))))
+
+(define-public aarch64-none-elf-newlib
+  (package
+    (name "aarch64-none-elf-newlib")
+    (version "2.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "ftp://sourceware.org/pub/newlib/newlib-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "01i7qllwicf05vsvh39qj7qp5fdifpvvky0x95hjq39mbqiksnsl"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:out-of-source? #t
+       ;; The configure flags are identical to the flags used by the "GCC ARM
+       ;; embedded" project.
+       #:configure-flags '("--target=aarch64-none-elf"
+                           "--enable-newlib-io-long-long"
+                           "--enable-newlib-register-fini"
+                           "--disable-newlib-supplied-syscalls"
+                           "--disable-nls")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-references-to-/bin/sh
+           (lambda _
+             (substitute* '("libgloss/aarch64/cpu-init/Makefile.in"
+                            "libgloss/aarch64/Makefile.in"
+                            "libgloss/libnosys/Makefile.in"
+                            "libgloss/Makefile.in")
+               (("/bin/sh") (which "sh")))
+             #t)))))
+    (native-inputs
+     `(("xbinutils" ,(cross-binutils "aarch64-none-elf"))
+       ("xgcc" ,aarch64-none-elf-gcc)
+       ("texinfo" ,texinfo)))
+    (home-page "https://www.sourceware.org/newlib/")
+    (synopsis "C library for use on embedded systems")
+    (description "Newlib is a C library intended for use on embedded
+systems.  It is a conglomeration of several library parts that are easily
+usable on embedded products.")
+    (license (license:non-copyleft
+              "https://www.sourceware.org/newlib/COPYING.NEWLIB"))))