diff mbox series

[bug#63446,2/2] gnu: Add r-ggpattern.

Message ID 20230511160412.18081-2-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#63446,1/2] gnu: Add r-gridpattern. | expand

Commit Message

Mădălin Ionel Patrașcu May 11, 2023, 4:04 p.m. UTC
* gnu/packages/cran.scm (r-ggpattern): New variable.
---
 gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d8bf51654c..a5292fec57 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20191,6 +20191,36 @@  (define-public r-ggextra
 marginal histograms/boxplots/density plots to ggplot2 scatterplots.")
     (license license:expat)))
 
+(define-public r-ggpattern
+  (package
+    (name "r-ggpattern")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggpattern" version))
+       (sha256
+        (base32 "1b9bfxlg64gr39bz58fp6jmg4nziwk8rk94rzpjsqhfhpwi2lrgr"))))
+    (properties `((upstream-name . "ggpattern")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-ggplot2
+           r-glue
+           r-gridpattern
+           r-rlang
+           r-scales))
+    (native-inputs (list r-knitr r-ragg r-rmarkdown))
+    (home-page "https://github.com/coolbutuseless/ggpattern")
+    (synopsis "Ggplot2 pattern geoms")
+    (description
+     "This package provides ggplot2 geoms filled with various patterns.  Includes
+a patterned version of every ggplot2 geom that has a region that can be filled
+with a pattern.  Provides a suite of ggplot2 aesthetics and scales for
+controlling pattern appearances.  Supports over a dozen builtin patterns (every
+pattern implemented by gridpattern) as well as allowing custom user-defined
+patterns.")
+    (license license:expat)))
+
 (define-public r-minpack-lm
   (package
     (name "r-minpack-lm")