@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2016, 2017, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2016, 2017, 2020, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
@@ -34,14 +34,14 @@ (define-module (gnu packages bdw-gc)
(define-public libgc
(package
(name "libgc")
- (version "8.0.6")
+ (version "8.2.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ivmai/bdwgc/releases"
"/download/v" version "/gc-" version ".tar.gz"))
(sha256
(base32
- "04ga3c95w5az5sznzm73j19lvvfpf6k4sgkpjqsmjxpsr6mi8j9v"))))
+ "181ni2rn9qjbl4ilqdjrd1a4h8siv5bgmzqgg4595q32n2y0f0gk"))))
(build-system gnu-build-system)
(arguments
(list
@@ -50,9 +50,6 @@ (define-public libgc
;; Install gc_cpp.h et al.
"--enable-cplusplus"
- ;; Work around <https://github.com/ivmai/bdwgc/issues/353>.
- "--disable-munmap"
-
;; In GNU/Hurd systems during the 'check' phase,
;; there is a deadlock caused by the 'gctest' test.
;; To disable the error set "--disable-gcj-support"
@@ -325,11 +325,8 @@ (define-public guile-3.0
(patches '())
;; Replace the snippet because the oom-test still
;; fails on some 32-bit architectures.
- (snippet '(begin
- (substitute* "test-suite/standalone/Makefile.in"
- (("test-out-of-memory") ""))
- (for-each delete-file
- (find-files "prebuilt" "\\.go$"))))))
+ (snippet '(for-each delete-file
+ (find-files "prebuilt" "\\.go$")))))
;; Build with the bundled mini-GMP to avoid interference with GnuTLS' own
;; use of GMP via Nettle: <https://issues.guix.gnu.org/46330>.
@@ -444,10 +441,7 @@ (define-public guile-next
(display ,version port)))))
(add-before 'check 'skip-failing-tests
(lambda _
- (substitute* "test-suite/standalone/test-out-of-memory"
- (("!#") "!#\n\n(exit 77)\n"))
- (delete-file "test-suite/tests/version.test")
- #t))))))
+ (delete-file "test-suite/tests/version.test")))))))
(native-inputs
(modify-inputs (package-native-inputs guile-3.0)
(prepend autoconf
@@ -571,10 +565,6 @@ (define-public guile-for-guile-emacs
(substitute* "test-suite/tests/version.test"
(("\\(pass-if \"version reporting works\"" m)
(string-append "#;" m)))
- ;; Warning: Unwind-only `out-of-memory' exception; skipping pre-unwind handler.
- ;; FAIL: test-out-of-memory
- (substitute* "test-suite/standalone/Makefile.am"
- (("(check_SCRIPTS|TESTS) \\+= test-out-of-memory") ""))
(patch-shebang "build-aux/git-version-gen")
(invoke "sh" "autogen.sh")