@@ -1923,6 +1923,7 @@ dist_patch_DATA = \
%D%/packages/patches/tuxpaint-stamps-path.patch \
%D%/packages/patches/twinkle-bcg729.patch \
%D%/packages/patches/u-boot-allow-disabling-openssl.patch \
+ %D%/packages/patches/u-boot-infodocs-target.patch \
%D%/packages/patches/u-boot-nintendo-nes-serial.patch \
%D%/packages/patches/u-boot-rockchip-inno-usb.patch \
%D%/packages/patches/u-boot-sifive-prevent-reloc-initrd-fdt.patch \
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2021 Stefan <stefan-guix@vodafonemail.de>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -62,6 +63,7 @@ (define-module (gnu packages bootloaders)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages serialization)
#:use-module (gnu packages swig)
#:use-module (gnu packages valgrind)
@@ -637,7 +639,8 @@ (define u-boot
(list %u-boot-rockchip-inno-usb-patch
%u-boot-allow-disabling-openssl-patch
%u-boot-sifive-prevent-relocating-initrd-fdt
- %u-boot-rk3399-enable-emmc-phy-patch))
+ %u-boot-rk3399-enable-emmc-phy-patch
+ (search-patch "u-boot-infodocs-target.patch")))
(method url-fetch)
(uri (string-append
"https://ftp.denx.de/pub/u-boot/"
@@ -667,6 +670,48 @@ (define u-boot
also initializes the boards (RAM etc).")
(license license:gpl2+)))
+;;; This is very similar to the linux-libre-documentation package, since it
+;;; reuses the same Makefile-based build system.
+(define-public u-boot-documentation
+ (package
+ (inherit u-boot)
+ (name "u-boot-documentation")
+ (arguments
+ (list
+ #:make-flags #~(list "HOSTCC=gcc"
+ ;; Avoid treating Sphinx warnings as errors.
+ "SPHINXOPTS=")
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (substitute* "doc/Makefile"
+ ;; Remove problematic environment check script.
+ ((".*scripts/sphinx-pre-install.*") ""))
+ (apply invoke "make" "infodocs" make-flags)))
+ (replace 'install
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (let* ((info-dir (string-append #$output "/share/info"))
+ (info (string-append info-dir
+ "/DasUBoot.info.gz")))
+ (with-directory-excursion "doc/output"
+ (apply invoke "make" "-C" "texinfo" "install-info"
+ (string-append "infodir=" info-dir)
+ make-flags))
+ ;; Create a symlink, for convenience.
+ (symlink info (string-append info-dir
+ "/uboot.info.gz"))))))))
+ (native-inputs
+ (modify-inputs (package-native-inputs u-boot)
+ (append fontconfig
+ python-sphinx
+ texinfo
+ which)))
+ (synopsis "U-Boot documentation")
+ (description "This package provides the documentation for U-Boot, as an
+Info manual.")))
+
(define-public u-boot-tools
(package
(inherit u-boot)
new file mode 100644
@@ -0,0 +1,61 @@
+Submitted upstream on Dec 16th, 2022.
+
+diff --git a/Makefile b/Makefile
+index de5746399a..597a8886c3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2372,7 +2372,7 @@ tcheck:
+ # Documentation targets
+ # ---------------------------------------------------------------------------
+ DOC_TARGETS := xmldocs latexdocs pdfdocs htmldocs epubdocs cleandocs \
+- linkcheckdocs dochelp refcheckdocs
++ linkcheckdocs dochelp refcheckdocs texinfodocs infodocs
+ PHONY += $(DOC_TARGETS)
+ $(DOC_TARGETS): scripts_basic FORCE
+ $(Q)$(MAKE) $(build)=doc $@
+diff --git a/doc/Makefile b/doc/Makefile
+index f5de65e927..62effd0fec 100644
+--- a/doc/Makefile
++++ b/doc/Makefile
+@@ -69,6 +69,15 @@ quiet_cmd_sphinx = SPHINX $@ --> file://$(abspath $(BUILDDIR)/$3/$4)
+ htmldocs:
+ @+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,html,$(var),,$(var)))
+
++texinfodocs:
++ @$(srctree)/scripts/sphinx-pre-install --version-check
++ @+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,texinfo,$(var),texinfo,$(var)))
++
++# Note: the 'info' Make target is generated by sphinx itself when
++# running the texinfodocs target defined above.
++infodocs: texinfodocs
++ $(MAKE) -C $(BUILDDIR)/texinfo info
++
+ linkcheckdocs:
+ @$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,linkcheck,$(var),,$(var)))
+
+@@ -109,6 +118,8 @@ cleandocs:
+ dochelp:
+ @echo ' U-Boot documentation in different formats from ReST:'
+ @echo ' htmldocs - HTML'
++ @echo ' texinfodocs - Texinfo'
++ @echo ' infodocs - Info'
+ @echo ' latexdocs - LaTeX'
+ @echo ' pdfdocs - PDF'
+ @echo ' epubdocs - EPUB'
+diff --git a/doc/media/Makefile b/doc/media/Makefile
+index b9b43a34c3..9b32258696 100644
+--- a/doc/media/Makefile
++++ b/doc/media/Makefile
+@@ -22,10 +22,11 @@ $(BUILDDIR)/linker_lists.h.rst: ${API}/linker_lists.h ${PARSER} $(SRC_DIR)/linke
+
+ # Media build rules
+
+-.PHONY: all html epub xml latex
++.PHONY: all html texinfo epub xml latex
+
+ all: $(IMGDOT) $(BUILDDIR) ${TARGETS}
+ html: all
++texinfo: all
+ epub: all
+ xml: all
+ latex: $(IMGPDF) all