diff mbox series

[bug#59416,1/1] gnu: ppsspp: Drop OGLCompiler and OSDependent from glslang libs.

Message ID 20221120180058.24278-1-i@dan.games
State New
Headers show
Series gnu: ppsspp: Drop OGLCompiler andOSDependent from glslang libs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

dan Nov. 20, 2022, 6 p.m. UTC
* gnu/packages/emulators.scm (ppsspp) [arguments]: Drop OGLCompiler and
OSDependent from lists of glslang libraries.
---
 gnu/packages/emulators.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 28d3e0ca9a..2ed5420aca 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2317,7 +2318,14 @@  (define-public ppsspp
            ;; Since we are not including git as an input, PPSSPP is confused
            ;; about its version.  Let's fix that here.
            (substitute* "git-version.cmake"
-             (("unknown") ,version))))))
+             (("unknown") ,version))
+           ;; We've updated the glslang in guix to match the latest vulkan-sdk
+           ;; version, while the glslang ppsspp vendored is a 2-year old
+           ;; version.  We have to manually remove these from glslang libs
+           ;; list to successfully build the package.  For more info, see:
+           ;; https://github.com/KhronosGroup/glslang/commit/7cd519511c32d7e86d901c7ed231cb84c652d18d
+           (substitute* "CMakeLists.txt"
+             (("OGLCompiler OSDependent") ""))))))
     (build-system cmake-build-system)
     (native-inputs (list pkg-config python))
     (inputs (list bash