diff mbox series

[bug#58179,2/4] gnu: Add node-commander.

Message ID 20220929195227.11018-2-ngraves@ngraves.fr
State New
Headers show
Series [bug#58179,1/4] gnu: Add node-ws. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Sept. 29, 2022, 7:52 p.m. UTC
* gnu/packages/node-xyz.scm (node-commander): New variable.
---
 gnu/packages/node-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 4c92e07537..c14ff7f421 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -106,6 +106,34 @@  (define-public node-color-name
      "This package provides a JSON list with color names and their values.")
     (license license:expat)))
 
+(define-public node-commander
+  (package
+    (name "node-commander")
+    (version "9.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tj/commander.js")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1yvm0qjirxxdrf7dng0h770n8abz83ymzv4r0wa8ww5x2l2xzsvz"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (replace 'configure
+                    (lambda _
+                      (invoke "npm" "--offline" "--ignore-scripts" "install"
+                              "--production"))))))
+    (home-page "https://github.com/tj/commander.js")
+    (synopsis "Complete solution for Node.js command-line interfaces")
+    (description "This package can parse arguments into options and
+command-arguments, disaply usage errors for problems, and implements a help
+system.")
+    (license license:expat)))
+
 (define-public node-crx3
   (package
     (name "node-crx3")