diff mbox series

[bug#43590,WIP,master] gnu: Add gobject-introspection+doctool.

Message ID 20200924134529.14435-1-dannym@scratchpost.org
State New
Headers show
Series [bug#43590,WIP,master] gnu: Add gobject-introspection+doctool. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Danny Milosavljevic Sept. 24, 2020, 1:45 p.m. UTC
* gnu/packages/glib.scm (gobject-introspection+doctool): New variable.
---
 gnu/packages/glib.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index ca037d3b24..0aa8c837cd 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -75,6 +75,7 @@ 
   #:export (dbus
             glib
             gobject-introspection
+            gobject-introspection+doctool
             dbus-glib
             intltool
             itstool
@@ -466,6 +467,19 @@  bindings to call into the C library.")
     ; Some bits are distributed under the LGPL2+, others under the GPL2+
     (license license:gpl2+)))
 
+(define gobject-introspection+doctool
+  (package
+    (inherit gobject-introspection)
+    (name "gobject-introspection+doctool")
+    (native-inputs
+     `(("python-mako" ,python-mako)
+       ("python-markdown" ,python-markdown)
+       ,@(package-native-inputs gobject-introspection)))
+    (arguments
+     (substitute-keyword-arguments (package-arguments gobject-introspection)
+      ((#:configure-flags flags ''())
+      `(cons* "-Ddoctool=true" ,flags))))))
+
 (define intltool
   (package
     (name "intltool")