diff mbox series

[bug#40601,13/28] guix-install.sh: Make grep & mktemp usage compatible with busybox.

Message ID 20200517171725.732-13-vincent.legoll@gmail.com
State Under Review
Delegated to: Christopher Baines
Headers show
Series [bug#40601,01/28] nix/local.mk: Add missing comment to sysvinit section. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll May 17, 2020, 5:17 p.m. UTC
The regex is not using pcre-specific syntax.
Busybox requires the mktemp template to end with 6 "X".  The longer template is
harmless for other systems.

* etc/guix-install.sh (guix_get_bin_list): Use grep -E instead of pcre.
(main): Use template that is accepted by busybox mktemp.
---
 etc/guix-install.sh | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index d6966f851a..770ecfaf3f 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -219,7 +219,7 @@  guix_get_bin_list()
         | sort -Vu)")
 
     latest_ver="$(echo "$bin_ver_ls" \
-                       | grep -oP "([0-9]{1,2}\.){2}[0-9]{1,2}" \
+                       | grep -oE "([0-9]{1,2}\.){2}[0-9]{1,2}" \
                        | tail -n1)"
 
     default_ver="guix-binary-${latest_ver}.${ARCH_OS}"
@@ -525,7 +525,7 @@  main()
     _msg "${INF}system is ${ARCH_OS}"
 
     umask 0022
-    tmp_path="$(mktemp -t -d guix.XXX)"
+    tmp_path="$(mktemp -t -d guix.XXXXXX)"
 
     if [ -z "$1" ]; then
         guix_get_bin_list "${GNU_URL}"