diff mbox series

[bug#39690,v2] gnu: Add pm_pcie_driver.

Message ID 20200220140107.24695-1-dannym@scratchpost.org
State Under Review
Headers show
Series [bug#39690,v2] gnu: Add pm_pcie_driver. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Danny Milosavljevic Feb. 20, 2020, 2:01 p.m. UTC
* gnu/packages/linux.scm (pm_pcie_driver): New variable.
---
 gnu/packages/linux.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

ashish.is--- via Guix-patches" via Feb. 20, 2020, 2:27 p.m. UTC | #1
Danny,

Danny Milosavljevic 写道:
> +       (uri 
> "https://www.passmark.com/downloads/pm_pcie_driver.tar.gz")

Are you a paying customer?  Any chance you could ask your rep for 
a versioned link?  :o)

> +    (license license:gpl2+)))

  ~/pm_pcie_driver λ grep -Eri "licen|gpl"
  pm_pcie_driver.c:MODULE_LICENSE("GPL");
  ~/pm_pcie_driver λ

Sigh.  Assuming for a moment that this is legal: wouldn't it be 
gpl2-only, like Linux?

LG otherwise!

Thanks,

T G-R
Danny Milosavljevic Feb. 20, 2020, 5:01 p.m. UTC | #2
Hi T G-R,

On Thu, 20 Feb 2020 15:27:59 +0100
Tobias Geerinckx-Rice <me@tobias.gr> wrote:

> Are you a paying customer?

Yes.

>  Any chance you could ask your rep for 
> a versioned link?  :o)

I'll try.

>   ~/pm_pcie_driver λ grep -Eri "licen|gpl"
>   pm_pcie_driver.c:MODULE_LICENSE("GPL");
>   ~/pm_pcie_driver λ
> 
> Sigh.  Assuming for a moment that this is legal: 


>wouldn't it be gpl2-only, like Linux?

Yeah, probably.

Thanks for the review!
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index aff8fd08fc..25dc756e56 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1046,6 +1046,26 @@  module allows the control of the backlight level or luminance property when
 supported under @file{/sys/class/backlight/}.")
     (license license:gpl2+)))
 
+(define-public pm_pcie_driver
+  (package
+    (name "pm_pcie_driver")
+    (version "2.0.1000")
+    (source
+     (origin
+       (method url-fetch)
+       (uri "https://www.passmark.com/downloads/pm_pcie_driver.tar.gz")
+       (sha256
+        (base32
+         "0xxyr7xi3j8v64yixzw01w7hi0c8pvd21wyr3k8fjiilvls2x9iw"))))
+    (build-system linux-module-build-system)
+    (arguments
+     `(#:tests? #f))                               ; no tests
+    (home-page "https://www.passmark.com/products/pcie-test-card/index.php")
+    (synopsis "Passmark PCIe test card driver")
+    (description "This package provides a Linux kernel driver for the Passmark
+PCIe test card.")
+    (license license:gpl2+)))
+
 
 ;;;
 ;;; Pluggable authentication modules (PAM).