diff mbox series

[bug#39617,1/2] gnu: Add linux-libre-pinebook-pro.

Message ID 20200215185209.28334-1-janneke@gnu.org
State Work in progress
Headers show
Series Add initial Pinebook Pro support | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

Janneke Nieuwenhuizen Feb. 15, 2020, 6:52 p.m. UTC
* gnu/packages/linux.scm (deblob-scripts-pinebook-pro): New function.
(linux-libre-pinebook-pro): Use it to declare new variable.
---
 gnu/packages/linux.scm | 48 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)

Comments

Vagrant Cascadian Feb. 20, 2020, 4:04 a.m. UTC | #1
Successfully booted! Thanks for your work on this! This is the first
time I've ever booted a new machine with Guix rather than Debian
proper. :)

Also the very first time I bootstrapped a Guix system from the guix
packages built for Debian! Need to just go ahead and upload those soon.

relatively minor issue below:

On 2020-02-15, Jan Nieuwenhuizen wrote:
> +;; Distribute a patched version of deblob-5.5 to accomodate for
> +;; the file rename
> +;;    drivers/crypto/ccp/psp-dev.c -> drivers/crypto/ccp/sev-dev.c
> +(define (deblob-scripts-pinebook-pro version)
...
> +        (origin
> +          (method url-fetch)
> +          (uri (string-append "https://linux-libre.fsfla.org"
> +                              "/pub/linux-libre/releases/" version "-gnu/"
> +                              "deblob-check"))

I had to change version to download deblob-check to "5.5.1" as
apparently the 5.5.0 version was removed from (or never present on)
linux-libre.fsfla.org.


live well,
  vagrant
Janneke Nieuwenhuizen Feb. 20, 2020, 6:26 a.m. UTC | #2
Vagrant Cascadian writes:

> Successfully booted! Thanks for your work on this! This is the first
> time I've ever booted a new machine with Guix rather than Debian
> proper. :)

\o/

> Also the very first time I bootstrapped a Guix system from the guix
> packages built for Debian! Need to just go ahead and upload those soon.
>
> relatively minor issue below:
>
> On 2020-02-15, Jan Nieuwenhuizen wrote:
>> +;; Distribute a patched version of deblob-5.5 to accomodate for
>> +;; the file rename
>> +;;    drivers/crypto/ccp/psp-dev.c -> drivers/crypto/ccp/sev-dev.c
>> +(define (deblob-scripts-pinebook-pro version)
> ...
>> +        (origin
>> +          (method url-fetch)
>> +          (uri (string-append "https://linux-libre.fsfla.org"
>> +                              "/pub/linux-libre/releases/" version "-gnu/"
>> +                              "deblob-check"))
>
> I had to change version to download deblob-check to "5.5.1" as
> apparently the 5.5.0 version was removed from (or never present on)
> linux-libre.fsfla.org.

Hmm; could be anything -- I'm hoping that we can move to a released
tarball + patches some time soon anyway; this one of th ugly bits.

Please feel free to push a fix!

Greetings
janneke
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 829bb09447..527180b522 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -39,6 +39,7 @@ 
 ;;; Copyright © 2019 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -872,6 +873,53 @@  It has been modified to remove all non-free binary blobs.")
                      #:defconfig "omap2plus_defconfig"
                      #:extra-version "arm-omap2plus"))
 
+;; Distribute a patched version of deblob-5.5 to accomodate for
+;; the file rename
+;;    drivers/crypto/ccp/psp-dev.c -> drivers/crypto/ccp/sev-dev.c
+(define (deblob-scripts-pinebook-pro version)
+  (list (version-major+minor version)
+        (origin
+          (method url-fetch)
+          (uri (string-append "https://lilypond.org/janneke/pinebook-pro/"
+                              "deblob-pinebook-pro-"
+                              (version-major+minor version)))
+          (file-name (string-append "deblob-" (version-major+minor version)))
+          (sha256
+           (base32 "15xpmn93mibgh3zlmbzfxx6hfk6y7vrwqc46gx7r87hrwhg0q4hj")))
+        (origin
+          (method url-fetch)
+          (uri (string-append "https://linux-libre.fsfla.org"
+                              "/pub/linux-libre/releases/" version "-gnu/"
+                              "deblob-check"))
+          (sha256
+           (base32 "12v9n7qf67vilwi2bkzbn1sbamhaw60rk79v3y2lm8bprgpy958l")))))
+
+;; This is apparently the least patched kernel (people call it "mainline",
+;; although it's not upstream), at the moment (Fri Feb 14 2020).  The exact
+;; version, branching, patchset is as yet unclear to me; the repository comes
+;; without any tags or upstream branches.
+(define-public linux-libre-pinebook-pro
+  (let* ((version "5.5.0")
+         (source
+          (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://gitlab.manjaro.org/tsys/linux-pinebook-pro.git")
+                  (commit "9564c96de3d1e7a19fbfed075333bf414fa1749f")))
+            (file-name (git-file-name "linux-libre-pinebook-pro" version))
+            (sha256
+             (base32
+              "0q4mrjvv7bpavd5r8k9njm0md0lymwcnjpd9nggb8vwffdgbchys"))))
+         (pristine-source (make-linux-libre-source
+                           "5.5.0-pinebook-pro" source
+                           (deblob-scripts-pinebook-pro version))))
+    (make-linux-libre*
+     version
+     pristine-source
+     '("aarch64-linux")
+     #:defconfig "pinebook_pro_defconfig"
+     #:extra-version "pinebook-pro")))
+
 
 ;;;
 ;;; Linux kernel modules.