From d6230c5286b95e9c8f2acc3662bddb1a20346251 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Thu, 13 Jun 2019 18:48:43 -0600
Subject: [PATCH] add freeorion * gnu/packages/games.scm (freeorion): New
variable.
---
gnu/packages/games.scm | 49 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)
@@ -7455,3 +7455,52 @@ steam locomotive across many levels and collect all the coaches to
win.")
;; The project is dual-licensed GPL2+ and GPL3+.
(license (list license:gpl2+ license:gpl3+))))
+
+(define-public freeorion
+ (package
+ (name "freeorion")
+ (version "0.4.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/freeorion/freeorion.git")
+ ;;Most recent stable release uses boost_signals (v1) which was later
+ ;;replaced with boost-signals2 and no longer exists. This commit builds
+ ;;and runs.
+ ;;TODO: Update this when the next stable release when it is available.
+ (commit "470d0711537804df3c2ca25532f674ab4bec58af")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wsw632l1cj17px6i88nqjzs0dngp5rsr67n6qkkjlfjfxi69j0f"))))
+ (arguments
+ '(#:tests? #f)) ;no test
+ (build-system cmake-build-system)
+ (inputs
+ `(("boost" ,boost)
+ ("boost_signals" ,boost-signals2)
+ ("freetype2" ,freetype)
+ ("glew" ,glew)
+ ("glu" ,glu)
+ ("libogg" ,libogg)
+ ("libpng" ,libpng)
+ ("libvorbis" ,libvorbis)
+ ("openal" ,openal)
+ ("python2" ,python-2.7)
+ ("sdl2" ,sdl2)
+ ("zlib" ,zlib)))
+ (home-page
+ "https://www.freeorion.org/")
+ (synopsis
+ "Turn-based space empire and galactic conquest computer game")
+ (description
+ "FreeOrion is a free, open source, turn-based space empire and galactic
+conquest (4X) computer game being designed and built by the FreeOrion project.
+Control an empire with the goal of exploring the galaxy, expanding your
+territory, exploiting the resources, and exterminating rival alien empires.
+FreeOrion is inspired by the tradition of the Master of Orion games, but is not
+a clone or remake of that series or any other game.")
+ (license (list
+ license:gpl2 ;game code, game content, scripts
+ license:cc-by-sa3.0))));artwork, music, sound, game content, scripts
--
2.22.0