diff mbox series

[bug#70620,3/3] gnu: librewolf: Update to 125.0.2-1.

Message ID 0f9ae67c356f59e3e2a3cb1274c3d0abf9a7d34a.1714263218.git.ian@retrospec.tv
State New
Headers show
Series Update LibreWolf to 125.0.2-1 | expand

Commit Message

Ian Eure April 28, 2024, 12:31 a.m. UTC
* gnu/packages/librewolf.scm (librewolf): Update to 125.0.2-1.  Build with
LLVM/Clang 18; LLVM 13 (the default) segfaults on build.  Minor style tweaks.

Change-Id: Ib515f1596b3ce2dd192baebf1a877b3c2dc8d7e2
---
 gnu/packages/librewolf.scm | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)

Comments

Ian Eure April 28, 2024, 12:41 a.m. UTC | #1
close 70621
close 70620
close 70619
thanks

help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your 
> message
> has been received.
>
> Your message is being forwarded to the package maintainers and 
> other
> interested parties for their attention; they will reply in due 
> course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, 
> please
> send it to 70620@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
diff mbox series

Patch

diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 1717bad0b5..fa83857c96 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -93,17 +93,17 @@  (define-module (gnu packages librewolf)
 ;; upstream.  See the file taskcluster/ci/toolchain/rust.yml at
 ;; https://searchfox.org under the particular firefox release, like
 ;; mozilla-esr102.
-(define rust-librewolf rust) ; 1.60 is the default in Guix, 1.65 is the minimum.
+(define rust-librewolf rust) ; 1.75 is the default in Guix, 1.65 is the minimum.
 
 ;; Update this id with every update to its release date.
 ;; It's used for cache validation and therefore can lead to strange bugs.
 ;; ex: date '+%Y%m%d%H%M%S'
-(define %librewolf-build-id "20240326080003")
+(define %librewolf-build-id "20240427150329")
 
 (define-public librewolf
   (package
     (name "librewolf")
-    (version "124.0.1-1")
+    (version "125.0.2-1")
     (source
      (origin
        (method url-fetch)
@@ -115,7 +115,7 @@  (define-public librewolf
                            version
                            ".source.tar.gz"))
        (sha256
-        (base32 "1sks49nywzhvq5mik4ipm3vyyxv49s9hq6bfyk5d9r6f0nlydllf"))))
+        (base32 "09qzdaq9l01in9h4q14vyinjvvffycha2iyjqj5p4dd5jh6q5zma"))))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -227,7 +227,8 @@  (define-public librewolf
                                                        "\""))))
                                    (find-files "." "Cargo\\.lock$"))
                          (for-each generate-all-checksums
-                                   '("build" "dom/media"
+                                   '("build"
+                                     "dom/media"
                                      "dom/webauthn"
                                      "gfx"
                                      "intl"
@@ -597,8 +598,8 @@  (define-public librewolf
     (native-inputs (list alsa-lib
                          autoconf-2.13
                          `(,rust-librewolf "cargo")
-                         clang
-                         llvm
+                         clang-18
+                         llvm-18
                          m4
                          nasm
                          node-lts